• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Script GPO
#1
Bonjour
je ne suis pas très doué en scripting

J'ai pris le script que vous avez mis en ligne et l'ai modifié avec mes infos mais rien ne s'installe sur les ordinateurs du domaine
je suis sur un Windows serveur 2012 et mon serveur glpi sur un linux Ubuntu 16.04

Code:
SetupVersion = "2.3.18"

SetupLocation = "\\SERVEUR-2012\Deploy\" & SetupVersion


' SetupArchitecture
'    The setup architecture can be 'x86', 'x64' or 'Auto'
'
'    If you set SetupArchitecture = "Auto" be sure that both installers are in
'    the same SetupLocation.
'
SetupArchitecture = "Auto"

' SetupOptions
'    Consult the installer documentation to know its list of options.
'
'    You should use simple quotes (') to set between quotation marks those values
'    that require it; double quotes (") doesn't work with UNCs.
'
SetupOptions = "/acceptlicense /runnow /no-ssl-check /server='xttp://192.168.1.12/glpi/plugins/fusioninventory/' /add-firewall-exception /installtasks=Full /execmode=Service /xttpd-trust='127.0.0.1,192.168.1.0/24' /S"

' Setup
'    The installer file name. You should not have to modify this variable ever.
'
Setup = "fusioninventory-agent_windows_" & SetupArchitecture & "_" & SetupVersion & ".exe"

Force = "No"

Verbose = "No"

*Est ce que cela vient des doubles quotes alors que c'est un UNCs?
Quand je les enlèves ça me mets des erreurs de syntaxes

*Du fait que les options du SetupOptions soit incorrectes?

PS: Faites pas gaffes aux xttp c'est parce que sinon il croit que c'est des liens et je n'arrivais pas à poster mon topic

Merci pour votre aide

Cordialement
  Reply
#2
Bonjour,
le même problème pour moi aussi.
Sauf que mon serveur GLPI est sous Win2008.

Merci pour votre aide.
  Reply
#3
Bonjour,
Ton \\SERVEUR-2012\Deploy\" & SetupVersion est il partagé et bien accessible par les clients ?
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#4
en fait le script marche si il est exécute manuellement mais pas par gpo

quand je fais gpresult, ça indique que la stratégie est bien appliqué mais rien ne s'installe...

d'ou cela peut il venir?
  Reply
#5
haha chez moi j ai le problème inverse Big Grin
Il y a pas des paramètre a mettre pour add-firewal-exception ?
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#6
ah mince lol

bah écoute je ne sais pas moi j'ai laissé comme ça

faudrait avoir l'avis de qqun pour qui l'install a fonctionné.

moi j'ai les options que tu vois dans le script au dessus.
  Reply
#7
Moi dans le script que j'ai je n ai que ces options la :
SetupOptions = "/acceptlicense /runnow /server='http://192.168.99.102/glpi/plugins/fusioninventory/' /S"
Ca fonctionne via GPO.

Tu as essayé sur ta gpo de mettre un script qui te créé juste un répertoire pour voir si elle est bien exécute ?
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#8
La j'ai réussi à faire marcher la gpo mais les agents ne remontent pas tous
et certains qui remontent ne restent pas dans fusion

je vais voir si ça ne vient pas du fait que les agents se fondent dans un autre pc qui a les mêmes infos comme dis dans ce topic

http://forum.fusioninventory.org/viewtopic.php?id=4953
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)