• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
configuration fusioninventory agent ubuntu
#1
Bonjour

Si vous pouvez m'aider ce serait sympatique.

l'agent fonctionne et remonte les infos dans glpi correctement,

1 -par contre impossible d'utiliser le serveur web de l'agent http://127.0.0.1:62354 que ce soit en local ou depuis le serveur glpi sur la machine.

2 - impossible de faire fonctionner en mode daemon

config de l'agent sur thinclient ubuntu

etc/init.d/fusioninventory-agent

# FusionInventory Agent Options
#
# MODE can be either "daemon" or "cron"
MODE=DAEMON
# You need to set the server in
# /etc/fusioninventory/agent.cfg

agent.cfg

# fusioninventory agent configuration

# all defined values match default
# all commented values are examples


#
# Target definition options
#

# send tasks results to an OCS server
#server = http://server.domain.com/ocsinventory
# send tasks results to a FusionInventory for GLPI server
server = http://itsm/glpi/plugins/fusioninventory/
# write tasks results in a directory
local = /tmp

#
# Task definition options
#

# disable software deployment tasks
#no-task = deploy

#
# Target scheduling options
#

# maximum delay before first target, in seconds
delaytime = 30
# do not contact the target before next scheduled time
lazy = 0

#
# Inventory task specific options
#

# do not list local printers
# no-category = printer
# allow to scan user home directories
scan-homedirs = 0
# allow to scan user profiles
scan-profiles = 0
# save the inventory as HTML
html = 0
# timeout for inventory modules execution
backend-collect-timeout = 30
# always send data to server
force = 0
# additional inventory content file
additional-content =

#
# Package deployment task specific options
#

# do not use peer to peer to download files
no-p2p = 0

#
# Network options
#

# proxy address
proxy =
# user name for server authentication
user =
# password for server authentication
password =
# CA certificates directory
ca-cert-dir =
# CA certificates file
ca-cert-file =
# do not check server SSL certificate
no-ssl-check = 1
# connection timeout, in seconds
timeout = 180

#
# Web interface options
#

# disable embedded web server
no-httpd = 0
# network interface to listen to
httpd-ip = 192.168.20.118
# network port to listen to
httpd-port = 62354
# trust requests without authentication token
httpd-trust = 127.0.0.1

#
# Logging options
#

# Logger backend, either Stderr, File or Syslog (Stderr)
#logger = stderr
# log file
#logfile = /var/log/fusioninventory.log
# maximum log file size, in MB
#logfile-maxsize = 0
# Syslog facility
logfacility = LOG_USER
# Use color in the console
color = 0

#
# Execution mode options
#

# add given tag to inventory results
tag =
# debug mode
debug = 0

#run as daemon
daemon = 1
  Reply
#2
Si tu lances fusioninventory-agent depuis une console, as tu des erreurs perl ?
  Reply
#3
De mémoire, regarde dans un répertoire du genre /etc/default/fusioninventory-agent.cfg
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#4
Salut,

dans ta conf, tu as:
Quote:httpd-ip = 192.168.20.118

Si c'est bien une ip de ton poste client, l'agent va ouvrir son daemon httpd sur cette ip.
Pour l'accès local, tu devras donc accéder par cette ip.

Le mieux reste de ne pas renseigner httpd-ip car l'agent écoutera sur toutes les ips locales. N'utilises httpd-ip que si tu sais que tu en as vraiment besoin.

Si c'est un reliquat de tests que tu as fait et que ça ne marchait pas non plus avec cette option désactivée, vérifie aussi que tu n'as pas un firewall actif sur ton poste.

Pour le mode daemon, ce n'est pas évident que ce soit possible par défaut. Quelle est la version du paquet que tu utilises ? ou sinon comment as-tu installé l'agent ?
Je travaille actuellement sur le packaging debian et à l'avenir cela fonctionnera par défaut en mode daemon.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)