• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Execute Task
Hello everyone, I have an old/new problem with Task excution.

In version 0.85 Tash schedule simply did not work ever. I had to use manual force of a task execution.

In version 0.90+1.4 force execution is even removed and task scheduler does not work. Time slot did not help either.

Can someone point me to an solution, thanks in advance.

Zoran A.
See http://fusioninventory.org/documentation/fi4g/cron.html
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
Thanks, configured -->> */1 * * * * /usr/bin/php /var/www/html/glpi/front/cron.php &>/dev/null
- stay as is.

Shall this crontab be configured for apache user or root only?
- I configured it for apache according to the doc I found.

This line executes the php script command every minute of every hour of every day of every month, is this ok?
- stay as is.

But, it is unclear which job will start and when. Is the schedule entry from the gui connected with this cron entry?
Does cron.php script scans tasklist from the web config and start to execute jobs one after another?
- I presume cron.php run tasks from the task list according to the time slot for instance, configured time slots.

I scheduled one job to start in two minutes but now have three jobs running, three prepared, one cancelled and the rest doing nothing.
- Still no tasks finishing its job, it enters prepared and then running state but ends with an error.

How to control scheduled inventory jobs better, one by one?
- Solved by time slots configured over the one week.

And, how to cancel specfic inventory job? Lots of vague entries, I need some hints to set it right.-
- In order to cancel the task, it should be deactivated.

Still, not able to make network discovery task finish its job, as if something is missing. In version 0.84, only one task was allowed to run at one period of time, was this changed in version 0.90?

Does anybody have experience woth configuring this in version 0.90? Help would be most appreciated.
Mr. Durieux, any ideas?

Thanx again, Zoran.
Also, I found plugin Fields to be very interesting, installed it but it throws an error at the end of configuration - http error 500.

Glpi v0.90+1.4, Fields plugin 0.90-1.3.

Anybody has an idea?
Fileds plugin problem solved.

Made discovery to work but associated SNMP inventory job does not start, the whole webpage hangs after job activation.
Newly created task for SNMP inventory does not start after successfully finished new network discovery task for a particular IP address range.
SNMP inventory works for old network discovery tasks imported from the previous version of fusion inventory/glpi.

SNMP auth associations to IP ranges were done. Current versions -->> Glpi 0.90.5, fusion 0.90+1.

Anybody has some idea?
In comparison to version 0.85, task scheduler is a mess in latest version of fi.
Topic could be closed.
a mess?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
Yes, a real mess. If I activate cron job -->> /usr/bin/php /var/www/html/glpi/front/cron.php &>/dev/null it will repeat a single discovery job even after the first job is finished successfully. How shall I know how long timeslot to be in order to configure it to prevent unwanted repetiion of discovery job?

Then, if I create a new discovery job it will finish successfully only if I configure timeslot -->> mon 00:00 to sun 24:00 and disable cron but run this command only once manually after I activate the job -->> /usr/bin/php /var/www/html/glpi/front/cron.php &>/dev/null.

When discovery successfully finishes, the snmp inventory wont start if I create it as a new job, simply it will not start, I also run -->> /usr/bin/php /var/www/html/glpi/front/cron.php &>/dev/null command manually to prevent it to create new inventory jobs. I am able to run previously created snmp inventory jobs but it seems they do not discover new that is newly added devices..

All those features worked very good in version 0.84 from whicih I upgraded to latest version.

The only thing that worked better in latest fi version are import rules - I managed to create printer import rule not to import printers with a specified name parts. The interface is also improved and looks better but some basic functionalities do not work as they should.

Forum Jump:

Users browsing this thread: 1 Guest(s)