• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FusionInventory client léger
#1
Bonjour à tous je rencontre un problème lors de l'installation de l'agent fusion inventory sur un client léger T510 HP qui est sous ubuntu , ci-dessous les message d'erreur rencontrés :
login as: root
fsunlock
cd /tmp/
dpkg -i fusioninventory-agent_2.1.10-1_i386.deb
Sélection du paquet fusioninventory-agent précédemment désélectionné.
(Lecture de la base de données... 57542 fichiers et répertoires déjà installés.)
Dépaquetage de fusioninventory-agent (à partir de fusioninventory-agent_2.1.10-1 _i386.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de fusioninventor y-agent :
fusioninventory-agent dépend de libxml-simple-perl ; cependant :
Le paquet libxml-simple-perl n'est pas installé.
fusioninventory-agent dépend de libnet-ip-perl ; cependant :

Avez-vous déjà rencontré ce problème? avez-vous réussi à installé fusioninventory-agent sur ce type de périphérique

Merci d'avance pour votre aide
  Reply
#2
Il te dis qu'il manque des dépendances, donc installes les dépendances Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Bonjour

Tu tombes bien je viens de finir l'installation sur un t520 apres pas mal de galere.

Solution :

decommenter dans etc/apt/sources.list deb h t t p://us.archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse

passer en admin mode
ouvrir un shell

fsunlock
apt-get update
apt-get install -y build-essential
apt-get install -y perl
apt-get -y install fusioninventory-agent

modifier le fichier agent.cfg avec le nom du serveur et daemon = 1

Seules choses que je n'arrive pas a faire c'est forcer l'inventaire depuis glpi de l'agent et lancer le serveur web http:adresseip:62354

J'espère que cela va t'aider
  Reply
#4
Bonjour ,

merci pour les infos j'ai enfin pu l'installer , à présent il faut que je le déploie à grande échelle sur notre parc de client léger via l'outil HPDM.

Bonne journée
  Reply
#5
je suis dessus aussi, je n'ai pas encore réussi.

copie de sources.list vers /etc/apt/
script
copie de agent.cfg déjà configuré vers etc/fusioninventory/

pour l'instant j'arrive a installer la version 2.2.3 de fuisionveintory agent impossible de trouver la source pour mettre la derniere version 2.3.17. aucun prob sous windows x86 et x64.

on peut travailler ensemble au fur et a mesure qu'on a des infos si tu veux.

A dispo

Yannick
  Reply
#6
Ca fonctionne avec hpdm voici la procedure

copie de sources.list vers /etc/apt/
script (voir contenu ci-dessous)
copie de agent.cfg déjà configuré vers etc/fusioninventory/

fsunlock
apt-get update
apt-get install -y build-essential
export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
apt-get install -y perl
apt-get -y install fusioninventory-agent
  Reply
#7
Super merci pour la marche à suivre.

Je vais tester et te tiens au courant
  Reply
#8
Pourrais-tu exporter les modèles que tu as créé sur hpdm et me les envoyer par mail stp?
  Reply
#9
malheureusement je n'ai pas accès au serveur pour récupérer des fichiers .
  Reply
#10
Merci beaucoup, il fallait connaitre le "décommenter" de la ligne du sources.list

Pour donner l'adresse du serveur à Fusion, on peut aussi utiliser :

fusioninventory-agent --server  http://ladressedemonserveurglpi/glpi/plugins/fusioninventory/
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)