• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLU] Pb installation agent Linux 2.3.18
#1
Bonjour,

Sur un 2ième Debian 8.5 virtualisé, j’ai voulu testé l’installation de l’agent 2.3.18.

J’ai fait l’installation des prérequis :

apt-get install libmodule-install-perl libmodule-build-perl libhttp-server-simple-psgi-perl libhttp-proxy-perl libio-captureoutput-perl libipc-run-perl libnet-snmp-perl libnet-telnet-cisco-perl libpoe-component-client-dns-perl libpoe-component-resolver-perl libtest-compile-perl libtest-deep-perl libtest-exception-perl libtest-most-perl libhttp-server-simple-authen-perl libio-capture-perl libio-captureoutput-perl libpoe-component-client-ping-perl libtest-http-server-simple-perl libtest-mockmodule-perl libtest-mockobject-perl libtest-nowarnings-perl libtest-failwarnings-perl libtest-warnings-perl libfile-copy-recursive-perl libxml-treepp-perl libproc-daemon-perl libproc-pid-file-perl

Et lorsque j’ai fait le perm Make.pl, j’ai eu les messages d’erreur suivants :

Warning: prerequisite Data::Structure::Util 0 not found.
Warning: prerequisite Parallel::ForkManager 0 not found.

J’ai vu sur que pour ce type de problème, il faut utiliser la commande suivante :

perl -MCPAN -e 'install "MODULE:MODULE"'

en mettant le nom du prérequis manquant à la place du Module. J’ai essayé toutes les combinaisons possibles sans succès.

Pour ForkManager, j’ai trouver :

apt-get install libparallel-forkmanager-perl

que je n’ai pas encore testé car la 2ième VM est chez moi.

Je n’ai rien trouvé Data::Structure::Util.

Quelqu’un a-t-il une ou plusieurs idées à me soumettre que je testerai ce soir.

Cordialement,
Cédric.
GLPI 0.90.5
FusionInventory 0.90+1.4
Installé sur Debian 8.5
Agent FusionInventory déployé 2.3.17 et 2.3.10
  Reply
#2
Bonjour,

Sans retour et sans trouvaille sur internet, j'ai regardé comment été construit la commande d'installation par rapport au message d'erreur pour ForkManager. J'ai reproduit la logique et j'ai ainsi trouver pour Warning: prerequisite Data::Structure::Util 0 not found :

apt-get install libdata-structure-util-perl

tout simplement et ça fonctionne.

Cordialement,
Cédric.
GLPI 0.90.5
FusionInventory 0.90+1.4
Installé sur Debian 8.5
Agent FusionInventory déployé 2.3.17 et 2.3.10
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)