• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Découverte SNMP
#1
Bonjour,

J'effectue actuellement un stage en entreprise pour ma dernière année d'école et l'on ma confié la tâche de migrer le GLPI + OCS et d'autres serveur web sur une machine Linux.

En plus de cela, étudier le passage à fusion inventory. La version de glpi est la 9.1.1 avec fusion 9.1+1.0.

J'ai donc installer mes divers vhost sur une machine CentOS + webmin/virtualmin.

-Installation de GLPI, OK
-Reprise des données OK
-Installation de fusion OK
-Remonter des agents OK

Mais ça commence à coincer lorsque j'essaie de créer une tâche pour scanner nos divers réseaux.

Nous disposons de plusieurs réseaux, le principal étant 192.168.0.0, et le dernier 192.168.8.0.

J'ai donc créer, des plages d'ip pour les différents sites (192.168.0.0-192.168.0.254)
(J'avais préparer pleins d'images, mais le forum ne me laisse en mettre qu'une, voilà donc un répertoire avec ces dernières)
https://cloud.anywen.ch/index.php/s/CAMFfjr2o8JSd2O -> plageIP.png

Suite à quoi j'ai activer les deux communautés SNMP disponibles
snmpCommunity.png

En ensuite créer une tâche, avec deux jobs, ipdiscover suivi d'un scan SNMP.
ipdisc.png et snmp.png

Mon agent est installé sur le serveur CentOS. Lorsque j'exécute la commande :
Code:
fusioninventory-netdiscovery --first 192.168.0.0 --last 192.168.0.254
J'ai tout mes périphériques réseaux qui s'affichent sans problème.

Lorsque je regarde dans fusioninventory->général->gestion des agents->agentLinux->informations d'import, j'ai ça qui s'affiche
historiqueAgent.png

J'ai comme l'impression que l'agent ne veut pas lancer mes tâches. Pourtant, ce dernier tourne en mode daemon
Code:
systemctl start fusioninventory-agent
, sa page web est accessible et il me dit qu'il effectue des communications avec le serveur.

La page de fusion m'affiche 2 postes fusion, le laptop sur le quel j'ai mis l'agent et mon agent linux. Mais aucune découverte réseau.
neant.png

Je ne sais plus trop ou regardé, ma tâche est active, j'ai augmenter le nombres d'actions, le cron glpi est mise en place, fusion ne m'indique pas d'erreurs, bref je galère.

N'hésitez pas à me demander des infos plus spécifiques, et merci d'avance.
  Reply
#2
Bon, après pas mal d'essais infructueux, j'ai enfin réussi à lancer une tâche. J'ai simplement mis à vide le champ "Heure de début programmé", fais un refresh avec le taskscheduler et mes tâches sont enfin envoyées à l'agent.
  Reply
#3
Bonjour,
l'inventaire réseau s'effectue ou juste la découverte ?
Car moi je n'arrive pas a executer la tâche d'inventaire.
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#4
Hello,

J'ai mis les deux jobs dans la même tâche, découverte suivie de l'inventaire et elle s'exécute sans problème. Je n'ai pas vraiment de différence dans le parc informatique du fait que nous tournions sur OCS avant et que les champs sont déjà bien renseignés.

Cependant, je rencontre un autre problème. Mon serveur se trouve sur le réseau 192.168.0.0, et comme exprimé plus haut, nous disposons de divers réseau.

Lorsque je lance un
Code:
fusioninventory-netdiscovery --first 192.168.8.0 --last 192.168.8.254
La commande me retourne les périphériques se trouvant sur l'autre site (vdi, imprimante, switch,...)

Par contre, la tâche qui se lance depuis l'interface web de fusion ne me retourne rien sur réseaux hors 192.168.0.0.

Edit : Si ça peut aider, le schéma réseau. Le serveur + agent se trouve donc sur ESxi 1 ou 2, par de problème pour la découverte pour 192.168.0.xxx, mais pas moyen pour les autres.

[Image: 1481892240-schemareseau.jpg]

Edit2 : Un exemple d'output de découverte réseau via la console :
Code:
fusioninventory-netdiscovery --first 192.168.4.1 --last 192.168.4.254
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <AUTHSNMP>1</AUTHSNMP>
      <CONTACT>Teradici HQ</CONTACT>
      <DESCRIPTION>Teradici SNMP Agent</DESCRIPTION>
      <IP>192.168.4.68</IP>
      <IPS>
        <IP>127.0.0.1</IP>
        <IP>192.168.4.68</IP>
      </IPS>
      <LOCATION>Burnaby, BC, Canada</LOCATION>
      <MAC>00:00:00:00:00:00</MAC>
      <SNMPHOSTNAME>Teradici Corp.</SNMPHOSTNAME>
      <UPTIME>4 days, 00:18:02.70</UPTIME>
    </DEVICE>
    <MODULEVERSION>2.2.1</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>NETDISCOVERY</QUERY>
</REQUEST>
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <AUTHSNMP>1</AUTHSNMP>
      <DESCRIPTION>Brother NC-8600h, Firmware Ver.E  ,MID 8CE-517,FID 2</DESCRIPTION>
      <IP>192.168.4.225</IP>
      <IPS>
        <IP>192.168.4.225</IP>
      </IPS>
      <LOCATION>DAC (2e etage)</LOCATION>
      <MAC>00:00:00:00:00:00</MAC>
      <MANUFACTURER>Brother</MANUFACTURER>
      <MEMORY>256</MEMORY>
      <MODEL>Brother MFC-L9550CDW</MODEL>
      <NETBIOSNAME>BRN30055C594EC3</NETBIOSNAME>
      <SERIAL>XXXXXXXXXXX</SERIAL>
      <SNMPHOSTNAME>BRN30055C594EC3</SNMPHOSTNAME>
      <TYPE>PRINTER</TYPE>
      <UPTIME>42 minutes, 43.30</UPTIME>
      <VENDOR>Brother</VENDOR>
    </DEVICE>
    <MODULEVERSION>2.2.1</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>NETDISCOVERY</QUERY>
</REQUEST>
Par contre, depuis l'interface GLPI, toujours le même petit message dans monitoring/log -> Total Found:0 Created:0 Updated:0
  Reply
#5
Bonsoir ANywen,
pour ma part même sur une nouvelle install j'ai le même problème !
La tâche de decouverte s execute mais pas celle d'inventaire ...
Il y a un truc que je dois zapper ...
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#6
Attention sur les sites distant, si les temps de réponses sont trop importants, il vaut mieux que ça soit un agent sur le site distant qui fasse le job
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#7
Hello, merci pour ta réponse. Effectivement, le temps de réponse est assez important entre les sites.
Je vais étudier la possibilité de poser des raspberry sur les sites en vdi.
  Reply
#8
Ah ben c'est ça alors Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)