• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation agent ligne de commande
#1
Bonjour a tous,
Je rencontre un problème pour l'installation de l'agent en ligne de commande. La commande ci dessous avait bien fonctionné chez moi sur mon pc perso, mais lors de test sur des VMs au boulot elle ne fonctionne pas (win 7 et 2012 server).

fusioninventory-agent_windows-x64_2.3.18.exe /acceptlicence /debug=2 execmode="Service" /installtasks="full" /runnow /S /local="D:\"

J'ai également tester :
fusioninventory-agent_windows-x64_2.3.18.exe /acceptlicense /runnow /local='C:\' /S

cette commande fonctionne dans le script executer par GPO mais pas lorsque je lance manuellement depuis l'invite de commande.
D’où peut provenir ce problème

Merci d'avance
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#2
j'ai trouvé mes commandes dans ce topic

peut etre que ça t'aidera ou une autre personne

http://forum.fusioninventory.org/viewtopic.php?id=4415
  Reply
#3
Bonjour,
merci pour ton retour.
Comme j'ai dis ma commande a fonctionné sur ma machine perso donc le problème ne se trouve sans doute pas la. Mais je ne comprend pas la raison
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#4
Tu lance bien sous un compte administrateur?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
Bonjour,
Oui je suis connecté avec un compte admins du domaine
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#6
remarque le \' ça doit échapper le ' essaye de doubler le \ comme ca :
\\'
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#7
Non toujours pareil ...
L'installeur se lance bien lorsque je tape juste fusioninventory-agent_windows-x64_2.3.18.exe.
Lorsque je fais la commande "fusioninventory-agent_windows-x64_2.3.18.exe /acceptlicence /debug=2 execmode=service /installtasks=full /runnow /local='D:\\'. Donc sans le /S j'ai le choix de la langue puis le navigateur qui s ouvre avec le liens vers la doc. Idem avec juste fusioninventory-agent_windows-x64_2.3.18.exe /acceptlicence
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply
#8
Salut,

attention, il faut bien noter qu'en anglais, 'licence' se traduit 'license', avec un "S".

Bref, sur les exemples donnés, tu utilises parfois l'option "/acceptlicence" alors qu'il faut utiliser "/acceptlicense" ... Je note aussi que parfois, tu mets aussi "execmode" en oubliant le "/" devant. J'imagine que ce ne sont que des typos sur ta retranscription de tes commandes, mais on sait jamais Wink

Enfin, l'option "/runnow" n'est pas indispensable quand tu actives le mode service.

Sur ma machine de test, config déjà dans la base de registre donc, la commande suivante fonctionne sans me poser de question:
Code:
fusioninventory-agent_windows-x64_2.3.18.exe /acceptlicense /S /execmode=service

En ajoutant juste les options de config nécessaire, ça devrait passer sans autre.
  Reply
#9
Bonjour,
merci pour ton retour,
il faudra que je regarde ça. Parfois j'ai retapé ma commande parfois j ai fais du copié collé !!
quel est le execmode par defaut ?

EDIT: Effectivement il semblerait que l'erreur venait de acceptlicenCe ... :/
GLPI V9.1.1 + FusionInventory Version 9.1+1.1 - Serveur Debian 8
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)