• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
http client : communication error: 500 Can't connect to ipserver:443
#1
Bonjour,

J'ai choisi de faire l'inventaire de l'existant informatique au travail et me penche donc vers la solution GLPI +FI dont j'ai pu lire du bien.

C'est ma première fois, voici ma configuration :

Un serveur Windows SBS2011 qui fait DC sur lequel j'utilise le IIS, pour l'installation de GLPI 9.1.2 + FI

Un client Windows 10 dans le domaine sur lequel j'ai installé avec FI-agent pour faire un premier test avant de déployer sur une cinquantaine de machines.

J'ai donc suivi des tutos videos et textes.

L'installation de GLPI s'est bien passée ainsi que celle du plugin FI, par contre aucune remontée de ma machine de test (W10) ne se fait.

En regardant le log de FI, je retrouve comme message d'erreur le sujet de mon post.

Dans la partie Administration --> Entités --> Entités Root de GLPI, l'URL d'accès au service est la suivante : http://ipserver/glpi/

Je ne vois pas ce qui bloque, visiblement un problème de communication

J'ai testé en cochant la case automatique durant l'installation et sans la cocher, ni l'un ni l'autre ne permettent les remontées de l'agent.

Autre chose que je ne saisi pas bien, selon le message d'erreur il est dit que FI ne peut se connecter à l'ip du serveur sur le port 443

Pourquoi 443 alors que mon adresse est en HTTP?

Merci pour votre aide
  Reply
#2
T'as mis quoi comme url du serveur quand tu as installé l'agent?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
ddurieux Wrote:T'as mis quoi comme url du serveur quand tu as installé l'agent?

http://ipserver/glpi/plugins/fusioninventory/
  Reply
#4
ca semble ok pourtant
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
le port 443 c'est pas plutot https ?
  Reply
#6
Ne serait-ce pas un problème de firewall, car ici nous avons une appliance firewall, faut-il ajouter une règle ?
  Reply
#7
asko Wrote:le port 443 c'est pas plutot https ?
Oui je me posais la question, j'ai pourtant tout mis en HTTP
  Reply
#8
ddurieux Wrote:ca semble ok pourtant
Pour info, ayant vu un de tes réponses au sujet de la version mac de l'agent FI ici, j'ai testé avec la version 2.3.18 de l'agent FI, mais toujours le même problème...
  Reply
#9
Voici ce que j'ai obtenu en ayant mis le mode debug à 2 dans l'installation de l'agent de FI 2.3.18 et en lançant l'interface GLPI à partir de mon serveur :

[http server] request / from client 127.0.0.1
[Fri Mar 10 14:22:36 2017][debug] [http server] response status 200
[Fri Mar 10 14:23:16 2017][debug] [http server] request /now from client 127.0.0.1
[Fri Mar 10 14:23:16 2017][debug] [http server] rescheduling next contact for all targets right now
[Fri Mar 10 14:23:16 2017][debug] [http server] response status 200
[Fri Mar 10 14:23:16 2017][debug] _runTarget
[Fri Mar 10 14:23:16 2017][debug] forking process -5248 to handle task NetInventory
[Fri Mar 10 14:23:16 2017][debug] NetInventory task not compatible with local target
[Fri Mar 10 14:23:22 2017][debug] forking process -3932 to handle task Collect
[Fri Mar 10 14:23:22 2017][debug] Collect task not compatible with local target
[Fri Mar 10 14:23:28 2017][debug] forking process -3232 to handle task WakeOnLan
[Fri Mar 10 14:23:28 2017][debug] WakeOnLan task not compatible with local target
[Fri Mar 10 14:23:34 2017][debug] forking process -5300 to handle task ESX
[Fri Mar 10 14:23:34 2017][debug] ESX task not compatible with local target
[Fri Mar 10 14:23:37 2017][debug] [http server] request / from client 127.0.0.1
[Fri Mar 10 14:23:37 2017][debug] [http server] response status 200
[Fri Mar 10 14:23:38 2017][debug] forking process -6728 to handle task Deploy
[Fri Mar 10 14:23:38 2017][debug] Deploy task not compatible with local target
[Fri Mar 10 14:23:44 2017][debug] forking process -5984 to handle task Inventory
[Fri Mar 10 14:23:44 2017][info] running task Inventory
  Reply
#10
Je viens de réinstaller la version 2.3.19 du FI et de nouveau le message d'erreur en lançant à partir de mon client W10 :

http client : communication error: 500 Can't connect to ipserver:443
  Reply
#11
UP ?
  Reply
#12
Bizarre, dans le log avec le debug à 2 que tu as mis, on ne voit pas d'erreur, donc la question est : d'ou tu sors ton erreur 500 sur 443???
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#13
En installant, je n'ai rien touché au firewall matériel que nous avons ici.
Ne serait-ce pas une question d'ouverture de port du firewall ?
  Reply
#14
Ca ne ferais pas une erreur 500, erreur 500 = erreur du serveur, donc les requetes arrivent bien sur le serveur
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#15
Bonjour,

Je me permets de répondre à ce post pour ne pas créer de nouveau topic car j'ai un problème quasi similaire.

Je suis sous GLPI 9.1.2 avec FusionInventory 9.1+1.0, les agents fusioninventory sont en versions 2.3.18 déployés par GPO. Pour 90% des machines de mon parc cela fonctionne sans problème, et pour les 10% restantes j'ai le message suivant dans les logs du fuisioninventory :
[error] [http client] communication error: 500 Can't connect to nomduserveur

Pour faire encore plus fort, dans ces 10% de machines qui déconnent, lorsque je force un inventaire manuellement via la page web de l'agent fusioninventory, cela fonctionne pour certaines, mais pas toutes !!

Une petite idée ? En sachant que tous les agents sont configurés de la même manière :/
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)