• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GPO Fusion inventory agent
#1
Bonjour,

Suite à vos tuto j'ai mis en place une GPO sur mon serveur 2008R2 en prenant en compte votre vbs pour la version 2.4, qui est celle que je veux mettre, en installant directement le .exe ça fonctionne.

J'ai mis le fichier vbs dans le fichier sysvol de l'AD avec les fichiers fusionInventory.adml et admx
Les exécutables dans un fichier sur le serveur pour le partage.

Dans la GPO j'ai juste mis le fichier vbs en scripts au démarrage, celui-ci est activé.

GLPI version 9.2.2 installé sous un windows 2008 aussi.

Test sur un poste sous windows 7 Pro

Ayant juste changé sur le vbs :

SetupLocation = "\\srv-xxxx\logiciels$\xxx\fusioninventory"
SetupOptions = "/acceptlicense /runnow /execmode=Service /server='hxxp://srv-xxxx/glpi/plugins/fusioninventory/' /S"

Celui-ci ne me met pas d'erreur lorsque sur un poste client de test je lance cscript.exe \\domain\sysvol\xxx\fusion-inventory.vbs

Donc le problème se situe surement sur le script pour ne pas qu'il se mette en place, je ne vois pas ou se situe le problème si quelqu'un aurais une idée, merci d'avance.

Je n'ai pas vu de ticket ouvert à ce propos.
  Reply
#2
Sur ton poste client il faut faire un gpupdate /force puis un gpresult /R /scope computer
afin de voir si la gpo va fonctionner
GLPI 9.2.2 / Debian 9 / php7.0 / mariaDB / FusionInventory 9.1+1.0
  Reply
#3
Bonjour ,

Pour le gpupdate /force et gpresult /R /scope computer, l'objet de stratégie de groupe fusion ( qui correspond juste à ce script) est présent parmi d'autres.

Mais rien dans C:\program files\ ou C:\programmes

Mais lorsque je lance cscript.exe \\domain\sysvol\xxx\fusion-inventory.vbs rien ne se passe, je sais pas si c'est normal.

merci
  Reply
#4
Bon erreur de ma part, ça fonctionne bien, sur mon chemin sysvol était "fusion inventory" et pas fusioninventory.

Merci de l'aide en tout cas marcbzh !
  Reply
#5
cool bonne nouvelle
GLPI 9.2.2 / Debian 9 / php7.0 / mariaDB / FusionInventory 9.1+1.0
  Reply
#6
En faite ca fonctionne que quand je fait cscript.exe \\domain\sysvol\xxx\fusion-inventory.vbs

Mais la GPO est bien présente et appliqué quand je fait gpresult /r /scope computer

Mais fusion ne s'installe pas

Dans filtrage du domaine j'ai ajouté utilisateur du domaine / ordinateurs du domaine pour des essais.

Edit : le processus fusioninventory-agent_windows-x64_2.4 est bien lancé sur un autre poste en test mais ne s'installe pas
  Reply
#7
quelques modification plus tard, le processus Perl Interpreter se lance bien avec le processus fusionInventory agent, mais page introuvable sur le navigateur avec l'adresse 127.0.0.1:62354
  Reply
#8
tu as rajouter une règle dans le pare-feu le port 62354 ?

il faut le faire
GLPI 9.2.2 / Debian 9 / php7.0 / mariaDB / FusionInventory 9.1+1.0
  Reply
#9
J'ai ajouté en option /add-firewall-exception puis whitelister sur mon antivirus.


Faut-il comme vu sur le forum glpi ajouter directement dans vbs cette commande ?

netsh advfirewall firewall add rule name="FusionInventory" dir=in action=allow protocol=TCP localport=62354 profile=mondomaine remoteip="adresse glpi"
  Reply
#10
Moi j'ai rajouté via une GPO ouverture du port sur les machines
GLPI 9.2.2 / Debian 9 / php7.0 / mariaDB / FusionInventory 9.1+1.0
  Reply
#11
Oui ,c'est plus simple de faire en plus dans la gpo "fusion" règles de trafic en laissant le protocole TCP sur le porte local 62354

Je lance et je fait le test après.

Par contre le site marche pas mais je viens de voir que la machines est bien remonté dans GLPI... Je pensé que si le site fonctionné pas, la remonté ne fonctionnais pas.
  Reply
#12
Bon ca a fonctionné sur 5 postes sur 150 je vois pas le problème, je l'ai bien mis en GPO machine, certains utilisateurs mon demandé qu'il faillais accepté ou pas la demande de windows pour l'installation. Quelqu'un à déjà eu le cas ?
  Reply
#13
Bon ça refonctionne à nouveau !!! Je sais pas, ce qui me manqué, modifié pas mal de chose... par contre j'ai des remontés de PC sous les noms (16) (17) etc...

Pour une info, la dernière modification sur le listing de GLPI correspond au dernier changement sur le poste ?
  Reply
#14
Pour un retour si besoin, c'est l'antivirus qui bloque FI malgré la whitelist....

Et si quelqu'un rencontre le problème pour les PC ou on ne vois pas les noms des postes mais qui affiche https://i.imgur.com/cEwUnNh.png les postes de façon croissant arrivant à (46)...
Je ne trouve pas ce problème sur le forum, si quelqu'un à une info la dessus.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)