• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Agent 2.5.1 Failed to load Proxy Server plugin
#1
I've got those messages with the new agent 2.5.1 on Windows 10 1903:

[Wed Jul 10 08:34:09 2019][debug] [http server] Trying to load Proxy Server plugin
[Wed Jul 10 08:34:09 2019][debug] [http server] Failed to load Proxy Server plugin: Can't locate XML/XPath.pm in @INC (you may need to install the XML::XPath module) (@INC contains: C:\Program Files\FusionInventory-Agent/perl/agent ./lib C:\Program Files\FusionInventory-Agent\perl\agent C:\Program Files\FusionInventory-Agent\perl\lib C:\Program Files\FusionInventory-Agent\perl\site\lib C:\Program Files\FusionInventory-Agent\perl\vendor\lib C:/Program Files/FusionInventory-Agent/perl/site/lib C:/Program Files/FusionInventory-Agent/perl/vendor/lib C:/Program Files/FusionInventory-Agent/perl/lib) at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Server/Proxy.pm line 8.
BEGIN failed--compilation aborted at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Server/Proxy.pm line 8.
Compilation failed in require at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Server.pm line 57.
[Wed Jul 10 08:34:09 2019][debug] [http server] Trying to load SecondaryProxy Server plugin
[Wed Jul 10 08:34:09 2019][debug] [http server] Failed to load SecondaryProxy Server plugin: Attempt to reload FusionInventory/Agent/HTTP/Server/Proxy.pm aborted.
Compilation failed in require at C:\Program Files\FusionInventory-Agent\perl\lib/base.pm line 137.
...propagated at C:\Program Files\FusionInventory-Agent\perl\lib/base.pm line 159.
BEGIN failed--compilation aborted at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Server/SecondaryProxy.pm line 8.
Compilation failed in require at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Server.pm line 57.
  Reply
#2
Hi luca.tolomelli,

yes I still saw this error. Don't worry, this just means new Proxy feature won't work under windows, but everything else works.

I should have missed something in the windows packaging related to the needed XML::XPath perl module. This module missing, the Proxy module doesn't compile. I'll take care of that problem asap and will publish another installer.
  Reply
#3
(2019-07-10, 07:54:05)gbougard Wrote: Hi luca.tolomelli,

yes I still saw this error. Don't worry, this just means new Proxy feature won't work under windows, but everything else works.

I should have missed something in the windows packaging related to the needed XML::XPath perl module. This module missing, the Proxy module doesn't compile. I'll take care of that problem asap and will publish another installer.

Ok, thank you! Smile
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)