• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Configuration non fonctionnelle :-(
#1
Bonjour,
j'utilise GLPI 9.4.3 sur Windows.
J'ai installé le plugins FusionInventory 9.4.1 
dans entité, j'ai ce paramètre dans 'URL d'accès au service ' : https://glpi.mondomaine.fr/glpi

nous sommes en https, que j'ai eu du mal à configurer, mais qui maintenant est fonctionnel.

Sur mon PC, en Windows10, j'ai installé l'agent FusionInventory en version x64 2.5.1

Rien ne remonte, dans les logs j'ai ces lignes en erreur :
[error] [http client] communication error: 500 Can't connect to glpi.mondomaine.fr:443 (Bad file descriptor)
[error] No answer from server at https://glpi.mondomaine.fr/glpi/plugins/...inventory/


Ca fait des heures que j'essaye de configurer pour avoir des remontées, mais rien à faire  Huh

à l'aide !
  Reply
#2
Une erreur 500 c'est plutôt côté serveur, donc regarde du côté du serveur web qui héberge GLPI dans les logs d'erreurs si tu trouves plus d'infos.
  Reply
#3
Sinon, et si ton certificat SSL server n'a pas été signé par une autorité publique, as-tu activé l'option "no-ssl-check" en installant ton agent ?
Tu peux toujours activer l'option dans la base de registre et redémarrer le service.
  Reply
#4
(2019-10-03, 07:34:58)gbougard Wrote: Sinon, et si ton certificat SSL server n'a pas été signé par une autorité publique, as-tu activé l'option "no-ssl-check" en installant ton agent ?
Tu peux toujours activer l'option dans la base de registre et redémarrer le service.

C'est un certificat 'wildcard' Gandi.
mais c'est effectivement peut-être là que ça pose problème...

dans les logs côté serveur il y a ce message d'avertissement :
[ssl:warn] [pid 3968:tid 384] AH01909: glpi:443:0 server certificate does NOT include an ID which matches the server name

Peut-être faut-il que j'abandonne le certificat Gandi au profit d'un certificat (plus simple ?), créé en interne ?
  Reply
#5
en tout cas, ça peut vouloir dire que l'agent ne va pas faire confiance au serveur et du coup, si tu veux laisser ta conf, tu devrais tester l'option "no-ssl-check" déjà.
  Reply
#6
Bonour,
je reviens vers vous après m'être battu avec GLPI et les certificats.
Finalement, je me suis créé un certificat de toute pièce : crt, key et csr généré avec openssl.
Je n'ai plus d'erreur sur le serveur GLPI.

Me voilà donc de retour avec FusionInventory ...
et là, toujours pareil :
[error] [http client] communication error: 500 Can't connect to glpi.mondomaine.fr:443 (Bad file descriptor)
[error] No answer from server at https://glpi.mondomaine.fr/plugins/fusioninventory/

en désactivant le controle SSL ça ne marche pas non plus , j'ai les 2 messages précédents.
  Reply
#7
As-tu bien vérifié que l'URL que tu utilises comme serveur côté agent est correcte ? Dans ton premier post, tu avais ton GLPI sous https://glpi.mondomaine.fr/glpi, ce qui plaçait l'URL d'accès au plugins pour l'agent sous https://glpi.mondomaine.fr/glpi/plugins/fusioninventory.

Sinon, essaies d'abord de valider que ça fonctionne en http:// sans SSL pour être certain que le problème n'est pas avec le support SSL.
  Reply
#8
j'ai ajouté ces lignes dans httpd.conf :
<Directory "c:/xampp/htdocs/glpi/plugins/fusioninventory">
Satisfy Any
Allow from all
</Directory>

et là, MIRACLE !!! cela fonctionne.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)