• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Deploiement de package en erreur
#1
Bonjour,

GLPI 9.4.4 / FI 2.5.1 / 9.4+1.1
Je viens de réinstaller un serveur GLPI / FI pour repartir sur une base propre.


Pour le déploiement de paquet : j'ai un partage Windows dans lequel j'ai mes setup et un .bat pour faire l'install silencieuse des applis.
Cote GLPI / FI, j'ai donc juste une action : \\nomserveur\partage\install.bat pour chaque appli

Sur mon ancien serveur GLPI, je fonctionnais comme ca, ca tournait impec (j'ai récupéré les paquets, les taches et les groupes)

Désormais, lorsque la tache se lance, j'obtiens sur le serveur l'erreur suivante" :
"L'agent demande une configuration qui lui a déjà été envoyée par le serveur. l'agent est susceptible d'avoir rencontré une erreur critique."

En créant une tache faisant juste un mkdir c:\toto, ca fonctionne. J'en conclu que l'agent/deploy est ok sur le client.

Une idée de l’origine de cette erreur ou comment je pourrais en savoir plus sur l'erreur rencontré ? log ou autre ?

Merci
  Reply
#2
Bonjour Istephane,

ce genre d'erreur peut arriver quand l'agent est lancé plusieurs fois sur une même machine. As-tu vérifié le journal d'un agent ?
Fais attention si tu as l'agent qui tourne en service et que tu essaies de l'exécuter aussi manuellement.

Sinon, as-tu essayé de forcer la tâche ?
  Reply
#3
Bonjour,

Sur un poste, je viens de réinstaller un agent en 2.4 (version qui foncitonnait avec mon ancien serveur GLPI).

J'ai créé un package :
1 - création d'un rep à la racine (mkdir c:\FI)
2 - copie d'un exe depuis un partage Windows (copy \\serveur\setup.exe c:\FI)
3 - Lancement de la commande setup.exe /S /v/qn (qui fonctionne bien en ligne de commande)

Etape 1 et 2 ok, la création du rep et la copie sont ok.
Etape 3 nok, j'ai sur le serveur l'erreur "Actions:c:\FI\CdR_X_2019.904.1.0.exe /S /v/qn, processing failure"

Que dois-je vérifier côté client dans les log ? j'ai mis le niveau de log à 2 lors de la réinstall.
Je confirme que l'agent est bien installé en tant que service sur le poste et que je force en faisant un http://localhost:62354/now

Jusqu'à présent je faisais comme ca lorsque je devais forcer une install.

Merci d'avance pour vos lumières, je ne sais plus où chercher.

Cordialement.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)