• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Test Agent Win2.1 RC3 / OCSNG 1.3.2
#1
Bonjour,
Je commence à tester l'agent Windows du 03/08, pour le moment uniquement avec OCS version 1.3.2 (sous Debian), donc quelques premières remontées que j'approfondirai un peu dans les prochains jours...

Le déploiement silencieux n'a pas posé de problème (méthode interne par psexec avec désinstallation préalable de l'agent OCS), les paramètres utilisés : "/silent /runnow /rpc-trust-localhost /server=http://serveur/ocsinventory"

Le runnow ne semble pas vraiment immédiat après l'installation, je n'ai pas vraiment encore fait attention au délai d'attente pour vérifier si l'argument est ignoré ou si c'est de l'impatience. Le http local a fonctionné également sans problème, pour lancer l'inventaire plus rapidement justement.

Sous Windows 7 x64, le serial n'est pas décodé (récupère BBBBB-BBBBB-BBBBB-BBBBB-BBBBB) alors que le ProductID est correcte, et pas de problème sur un XP x86. Peut-être un changement de cryptage de l'ID ? La récup fonctionne avec Magical Jelly mais pas avec WinKeyFinder par ex.

Pour la mémoire, c'est le grand mystère, 4Go sur mon 7x64, 8Go détectés par l'agent :
Code:
XMM1         DIMM      2048        1333      1     A9185AE1
XMM3         DIMM      2048        1333      3     A8185AE1
SYSTEM ROM   Chip      4096         Flash     5     Not Specified
XMM2         DIMM      No                         2
XMM4         DIMM      No                         4
2Go sur le XPx86, 6Go détectés :
Code:
XMM1         DIMM     1024       DDR2     800     1       CF7D0EE8
XMM3         DIMM     1024       DDR2     800     3     D07D0EE8
SYSTEM ROM   Chip      4096      Flash                5     Not Specified
XMM2         DIMM      No         DDR2               2      
XMM4         DIMM      No         DDR2               4

Pour les slots et les ports, j'ai également l'impression que tout est doublé, ex :
Code:
PCI1      32-bit PCI      1
PCI EXPRESS x1 SLOT 1 (PCIEx1 1)     x1 PCI Express     1
PCI EXPRESS x1 SLOT 2 (PCIEx1 2)     x1 PCI Express     1
PCI EXPRESS x16 SLOT (PCIEx16)     x16    
Connecteur système     Connecteur système     PCI1
Connecteur système     Connecteur système     PCI EXPRESS x1 SLOT 1 (PCIEx1 1)
Connecteur système     Connecteur système     PCI EXPRESS x1 SLOT 2 (PCIEx1 2)
Connecteur système     Connecteur système     PCI EXPRESS x16 SLOT (PCIEx16)
Code:
SATA      SATA0      None      SAS/SATA Plug Receptacle
SATA     SATA1     None     SAS/SATA Plug Receptacle
(...)
Unknown      SATA0      SATA0      SATA0
Unknown     SATA1     SATA1     SATA1

A moins qu'OCS n'ait conservé les données de l'ancien agent ? Je testerai la suppression un peu plus tard (edit : sans effet)

La récup de données dans la BdR semble ok sur le XP également (pas de données sur le W7)

A bientôt !
Anthony.

Edit1 : Pas de remontée d'écran sur les deux PC... Les LG ne sont pas compatible EDID (pour le serial réel en tout cas), mais un minimum d'info est quand même utile.
La suppression de la machine dans OCS ne change rien pour les doublons mémoire, d'ailleurs la ROM doit plutôt correspondre aux 4Mo de Bios ou équivalent ? (PCs HP 5800 et 6000)
Glpi 0.85.2 + Plug'in Fusion Inventory 0.85+1.1 + Agents Fusion 2.3.15
Serveur Debian 7, Apache 2.2.22, PHP 5.4.36
  Reply
#2
Pour info, le code vbs donné sur ce site retourne correctement le numéro de série de mon Windows 7.
Edit : le numéro de série de ce PC est celui d'un préload OEM, et pas celui de "l'étiquette", c'est peut-être la raison de ce "BBBBB" ?
Glpi 0.85.2 + Plug'in Fusion Inventory 0.85+1.1 + Agents Fusion 2.3.15
Serveur Debian 7, Apache 2.2.22, PHP 5.4.36
  Reply
#3
Salut Anthony,

Je viens de créer deux tickets pour ces problèmes :
http://forge.fusioninventory.org/issues/267
http://forge.fusioninventory.org/issues/268
http://forge.fusioninventory.org/issues/269

Merci pour tes retours. Serait-il par hasard possible d'avoir accès en RDP à ton Windows pour faire les corrections plus rapidement ? Si oui tu peux me contacter ici goneri@rulezlan.org

Encore merci Smile
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#4
goneri Wrote:Je viens de créer deux tickets pour ces problèmes :
http://forge.fusioninventory.org/issues/267
http://forge.fusioninventory.org/issues/268
http://forge.fusioninventory.org/issues/269
Pour la prise en main ça n'est vraiment pas possible, on a déjà du mal avec nos fournisseurs officiels :/

Concernant le point 268, c'est indépendant du système, il s'agit certainement de deux erreurs :
- L'agent Fusion qui renvoie les mémoires flash à 4096Mo alors que ce devrait être 4096ko (="4" avec l'agent OCS sur un autre PC)
- Le serveur OCS ne devrait pas additionner ROM et RAM, d'ailleurs cette info ROM aurait plus sa place à côté des infos du BIOS je pense (modèle/version/date/+"taille").
En tout cas il ne faudrait pas "tagguer" ce composant en tant que mémoire vive, je ne sais pas qui le fait en pratique.


Le doublon des ports/slots est donc un problème différent, une fois dans Glpi (via mass import) on se retrouve par exemple avec : "FRONT CHASSIS FAN" et "Unknown FRONT CHASSIS FAN" (il y a une détection des ports ventilo ?! :o )


J'ai testé sur un PC Japonais sous XP, pas d'amélioration du support UTF8 mais cela vient du serveur OCS, à voir qui du plugin Fusion ou d'un Serveur OCS UTF8 friendly sortira le premier Wink


Les modems ne semblent pas remontés non plus, l'icône OCS reste grisé, mais ils apparaissent bien dans les périphériques... il faut que je vois plus précisément un avant/après sur un autre poste.

Vive le boulot mois d'août, on a enfin un peu de temps Big Grin
Glpi 0.85.2 + Plug'in Fusion Inventory 0.85+1.1 + Agents Fusion 2.3.15
Serveur Debian 7, Apache 2.2.22, PHP 5.4.36
  Reply
#5
Merci pour ces retours Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#6
Pour l'histoire de la ROM, je viens de faire un petit correctif pour qu'on ignore ce type de mémoire dans le futur. Tu peux trouver un paquet avec ce correctif ici :
http://prebuilt.fusioninventory.org/devel/windows-i386/

Pour ce qui est du PC Japonais, je pense justement que ça doit être fachement car j'ai corrigé beaucoup de bug UTF-8 la nuit dernière. Cependant, ces fixes ne sont pas dans la rc3. Il faut mieux passer par ce paquet encore une fois : http://prebuilt.fusioninventory.org/devel/windows-i386/

Pour les ventilo, c'est assez compliqué de filtrer de ces composants de la carte mère. Je préfère donc les inventorier tous plutôt que faire un filtrage arbitraire. Pour bien faire, il faudrait une section <FANS></FANS> dans l'inventaire. Tu en penses quoi ?

Pour le modem, tu as raison. En faite, je n'ai pas trouvé de machine avec un modem pour faire mes tests jusqu'a présent Undecided Je viens d'ouvrir un bug pour faire une trace (http://forge.fusioninventory.org/issues/270) mais je doute que se sera corrigé pour la 2.1 a moins que tu penses que c'est vraiment important.

Comme dit David, merci pour tes retours. N'hésite pas a ouvrir un bug (en anglais) dès que tu trouves un truc qui ne te convient pas. C'est plus simple a tracer pour nous.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)