• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Mac OS X] Firewall exeption for perl
#1
Hi
I am trying to deploy the fusion-inventory client on a few hundred Mac's. Because the Firewall is enabled, after installation I get a prompt to allow traffic for perl (which is part of fusion-inventory). As the command line options of the application layer firewall in Snow Leopard are broken, I haven't found a way to avoid this prompt without user interaction. Does anyone know a solution for this?
Thanks
generic
  Reply
#2
Hello,
can you give me the exact version of snow leopard ?
I've never experienced such issues for the moment

once the traffic is allowed, does the inventory works well ?
  Reply
#3
It is 10.6.8. /usr/libexec/ApplicationFirewall/socketfilterfw is broken since 10.5 but should be fixed in 10.7. It works fine if I accept the traffic by prompt or add an exception rule in the Firewall GUI.
Digitally-signed apps are automatically trusted by the firewall. You can check for trusted app with sudo /usr/libexec/ApplicationFirewall/socketfilterfw -l | grep TRUSTEDAPPS.
  Reply
#4
Hello,

I've never experienced this kind of problem.
maybe we could try to do something like this to open a port on the firewall http://hints.macworld.com/article.php?st...5142113281 ?
what do you think about it ?
  Reply
#5
Hello,

Can you add this:
no-socket=1

In the agent.cfg file? With this option the agent won't try to open a socket on the network.

Best regards
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#6
I've already set this.
Regards
generic
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)