• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Agent Fusioninventory avec proxy squid
#1
MAJ 12/03/2013

Bonjour,

Je reviens sur le sujet avec une variante.
J'utilise l'agent fusioninventory 2.2.7-3 sur des postes en windows 7 pro 64 bits.
Ils sont en adresse ip privée et passe donc par un proxy squid sans authentification http://proxy:8080
le serveur glpi est en https.
Les clients ne remontent pas et j'ai une erreur:
[Mon Feb 11 17:24:55 2013][error] [http client] communication error: 501 Not Implemented
[Mon Feb 11 17:24:55 2013][fault] No answer from the server at C:\Program Files (x86)\FusionInventory-Agent\perl\agent/FusionInventory/Agent.pm line 248.

Avez vous une idée, une piste ?

merci,
  Reply
#2
quel est le système d'exploitation où l'agent est installé?
  Reply
#3
Tu as mis quoi comme adresse serveur dans la conf de l'agent?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#4
Bonjour,

https://glpi.xxx.fr/plugins/fusioninventory/
elle fonctionne bien avec les postes en adresse ip publique qui ne passe pas par le proxy.

merci,
  Reply
#5
Alors là, tu poses une colle Sad
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#6
Aie c'est pas bon signe ça. ;-)
Tu connais des configurations squid + glpi en https + agent fusioninventory qui fonctionne ?

Je vais creuser du coté de la configuration squid.

merci,
  Reply
#7
Salut

Tu as quoi dans ta clé “proxy” ?
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#8
Salut,

Quand j'installe mon client voici le proxy que je déclare http://proxyxxx.fr
J'ai aussi essayé:
IP du serveur
http://proxyxxx.fr:8080

merci,
  Reply
#9
http://proxyxxx.fr:8080 devrait marcher. Vous avez un log ? http://www.fusioninventory.org/documenta...bugreport/
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#10
j'avais pas grand chose de plus que ça
[Mon Feb 11 17:24:55 2013][error] [http client] communication error: 501 Not Implemented
[Mon Feb 11 17:24:55 2013][fault] No answer from the server at C:\Program Files (x86)\FusionInventory-Agent\perl\agent/FusionInventory/Agent.pm line 248.

merci,
  Reply
#11
Bonjour,

Voici les logs de squid
Quand je vais sur le serveur avec firefox:
192.168.48.100 NONE/501 3756 POST https://glpi.xxxx.fr/plugins/fusioninventory/ - NONE/- text/html
1360746425.114 13 192.168.XX.XXX TCP_MISS/301 636 GET http://glpi.xxxxx.fr/ - DIRECT/19X.XXX.XXX.XX text/html
1360746425.260 93 192.168.XX.XXX TCP_MISS/200 971 POST http://ocsp.tcs.terena.org/ - DIRECT/178.255.83.1 application/ocsp-response
1360746425.430 87 192.168.XX.XXX TCP_MISS/200 970 POST http://ocsp.usertrust.com/ - DIRECT/178.255.83.1 application/ocsp-response
1360746426.079 471 192.168.XX.XXX TCP_MISS/200 2852 CONNECT glpi.xxxxxx.fr:443 - DIRECT/19X.XXX.XX.XX -
1360746430.950 5803 192.168.XX.XXX TCP_MISS/200 49194 CONNECT glpi.xxxxx.fr:443 - DIRECT/19X.XXX.XX.XX -

Avec le client fusion:
1360747677.193 0 192.168.XX.XXX NONE/501 3756 POST https://glpi.xxxxx.fr/plugins/fusioninventory/ - NONE/- text/html
et rien d'autre.

Cote client:
[Wed Feb 13 09:33:32 2013][debug] [http server] request /now from client 127.0.0.1
[Wed Feb 13 09:33:32 2013][debug] [http server] valid request, forcing execution right now
[Wed Feb 13 09:33:34 2013][debug] [http server] request / from client 127.0.0.1
[Wed Feb 13 09:33:36 2013][debug] [http client] Using Compress::Zlib for compression
[Wed Feb 13 09:33:36 2013][debug2] [http client] sending message:
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
<DEVICEID>admv-222-04-2013-02-13-08-27-55</DEVICEID>
<QUERY>PROLOG</QUERY>
<TOKEN>MMIDRBUW</TOKEN>
</REQUEST>

[Wed Feb 13 09:33:36 2013][error] [http client] communication error: 501 Not Implemented
[Wed Feb 13 09:33:36 2013][fault] No answer from the server at C:\Program Files (x86)\FusionInventory-Agent\perl\agent/FusionInventory/Agent.pm line 248.

Bug fusioninventory ou squid ou moi ?
  Reply
#12
Essaye de mettre l'url : https://glpi.xxxx.fr/plugins/fusioninven...cation.php dans la conf de l'agent
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#13
Même erreur avec cette url
  Reply
#14
idem, je n'étais pas parvenus à faire communiquer, en https, un agent derrière un proxy squid et un serveur GLPI. J'ai laissé en http du coup :/
  Reply
#15
ça semble être un bug, pouvez-vous le déclarer sur la forge ?
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#16
Salut,

Merci Oviri je me sens moins seul ;-)
Oui Goneri j'ai fais une demande dans forge. http://forge.fusioninventory.org/issues/1940

merci,
  Reply
#17
Bonjour,

Pas de nouvelles infos ? pistes ?

a+
  Reply
#18
Bonjour,
je suis dans le même cas...
  Reply
#19
Bonjour,

En HTTPS, l'agent parle au proxy comme si il était le serveur final. C'est un bug connu de la librairie qu'on utilise.
Je cherche une solution simple. Pour le moment un test unitiaire a été ajouté. En attendant, je ne vois pas d'autre
solution que de laisser HTTP pour les remontées d'inventaires.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#20
Merci pour la réponse et les tests.
Dans l'attente d'une amélioration, on va partir sur du NAT pour éviter le proxy.
  Reply
#21
Bonjour,

Est-ce qu'une solution au problème a été trouvée ?

Est-ce que la version 2.3.0 de l'agent corrige l'erreur ?

Merci d'avance de la réponse.
  Reply
#22
Bonjour emergiaa,

Non malheureusement, le problème existe toujours avec la version 2.3.0. Vous pouvez suivre l'évolution sur bug ici http://forge.fusioninventory.org/issues/1940
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#23
tiens tiens exactement le même problème que je rencontre et pour lequel je n'ai eu de réponse la --> http://forum.fusioninventory.org/viewtopic.php?id=2032
On va attendre l'évolution du Bug dans ce cas .
  Reply
#24
The situation is improving a lot: http://ddumont.wordpress.com/2013/12/07/...in-debian/
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#25
Pour information, j'ai testé aujourd'hui le paquet Debian libwww-perl 6.05-2 qui semble bien marcher. Il intègre le patch officiel pas encore publié officiellement ( http://patch-tracker.debian.org/package/...erl/6.05-2 ) qui est disponible aussi ici : https://github.com/libwww-perl/libwww-perl/pull/52
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)