• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Liaison entre équipements réseau
#1
Je suis en train de migrer de OCS vers GLPI 0.85/Plugin Fusion 2.4.0/agents 2.1.10 sous Debian.

Je ne comprends pas la logique de liaisons entre 2 équipements réseau. C'est comme si les équipements s'interchangeaient leur IP.
Exemple : j'ai une pile de commutateurs Cisco 3750 IP1/MAC1 (renseigné dans la fiche principal et non comme port réseau de type interface VLAN, sinon, l'inventaire SNMP ne fonctionne pas) connecté au 2 interfaces d'un routeur VPN Cisco 1640
- Fa0/1 IP2/MAC2 dans le VLAN2 et sur le port G2/0/21 du commutateur
- Fa0/0 IP3/MAC3 dans le VLAN3 et sur port Gi2/0/23 du commutateur

1- l'appartenance aux VLAN n'est pas remonté, ni dans connexions, ni dans Fusinv SNMP,
2- de plus, curieusement, les ports des 2 équipements héritent de l'IP du port de l'équipement sur lequel il est connecté.
Ce qui fait que :
- les ports Fa0/0 et Fa0/1 du routeur ont l'IP du commutateur,
- les ports du commutateur G2/0/21 et Gi2/0/23 ont IP2 et IP3 comme adresse, alors que ce sont des ports d'accès, normalement sans IP ....
Cette échange d'IP n'a pas lieu avec les ordinateurs connectés au commutateur.

Même chose avec un trunk avec aggrégation de lien entre 2 commutateurs : les IP sont échangées de part et d'autre du trunk.

Quelque chose m'aurait-il échappé ?

Merci d'avance
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#2
Oula c'est un peu mic mac là, je ne comprend plus cequi est Cisco 3750 et ce qui est VPN Cisco 1640
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Je reprends donc :

j'ai un routeur VPN Cisco 1640
Fa0/0 : IP1
Fa0/1 : IP2

connecté
sur un commutateur Cisco 3750 avec une adresse dans le VLAN 2 IP3

Lors de l'inventaire réseau,
l'onglet Connexions montre :
- que les ports du commutateurs sur lesquels sont connectées les 2 interfaces du routeur VPN héritent des adresses de ce routeur IP1 et IP2, ce qui n'a pour moi, pas de sens : ce sont des ports d'accès, sans adresse IP
- que l'interface Fa0/1 du routeur se retrouve avec comme IP ... celle du commutateur IP3.

C'est comme si les ports des équipements réseau s'échangeaient leur adresse IP.
Est-ce plus clair ?
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#4
ouais, t'aurais une capture d'écran ou tu vois ces IP ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
Comment fait-on pour insérer des images ?
J'ai bien compris comment les insérer dans le BBcode mais comment les télécharger ?
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#6
faut les héberger ailleurs genre sur http://www.hostingpics.net/ et mettre le lien ici
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#7
Voici :

le commutateur :
http://www.hostingpics.net/membres/voir,...ng,22.html
le routeur VPN :
http://www.hostingpics.net/membres/voir,...ng,22.html

Mais c'est un exemple. Il se passe la même chose pour un trunk entre 2 commutateurs
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#8
Arf t'as cree un compte :/ je n'ai pas de compte pour voir les images Sad
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#9
Décidemment.

Commutateur :
[Image: 9638803750.png]


routeur VPN ;
[Image: 7147031640.png]
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#10
C'est mieux Wink

L'ip qui est tout à droite c'est l'IP du matériel sur lequel le port est connecté, l'ip du port c'est l'ip qui est à coté de la colonne "prise réseau"
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#11
C'est bien là le problème :

Pour les ports G1/0/22 et G1/0/23 du commutateur, il ne devrait pas y avoir d'IP dans la colonne à droite de "Prise Réseau". Le commutateur à bien une interface VLAN avec comme adresse 172.27.0.40 mais qui ne devrait de toute façon apparaître sur aucun port physique.

De même sur le routeur, dans la colonne à droite de "Prise Réseau", je devrais avoir 212.99.4.74 pour Fa0/0 et 172.27.2.22 pour Fa0/1 et non l'IP du commutateur.

Pour moi, il y a une inversion.
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#12
Ca me parait bon, Gi1/0/22 a l'ip 172.27.2.22 et est connecté sur Fa0/1 qui a l'IP 182.27.0.40, dont on retrouve bien les ip distant du port sur lequel il est connecté avec son IP
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#13
Bon je recommence :
la réalité est la suivante (show run en ligne de commande) :

Le routeur VPN :
#############
interface Fa0/0
description Interface_ISP
ip address 212.99.4.74 255.255.255.240

interface Fa0/1
description Interface_DMZ_VPN
ip address 172.27.2.22 255.255.255.240


On devrait avoir dans GLPI :
F0/0 212.99.4.74 connecté à G1/0/23 sur sw1 (sans IP)
F0/1 172.27.2.22 connecté à G1/0/22 sur sw1 (sans IP)

Le commutateur :
#############
interface GigabitEthernet1/0/22
description VPN1-7
switchport access vlan 7
switchport mode access
spanning-tree portfast

interface GigabitEthernet1/0/23
description VPN1-212
switchport access vlan 212
switchport mode access
spanning-tree portfast

interface Vlan2
ip address 172.27.0.40 255.255.255.0

On devrait avoir donc dans GLPI :
G1/0/22 connecté à Fa0/1 sur vpn1 172.27.2.22
G1/0/23 connecté à Fa0/0 sur vpn1 212.99.4.74

Et l'IP 172.27.0.40 ne devrait jamais apparaître en tant qu'IP d'un port physique.


GLPI dit le contraire.
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#14
ah oui en effet, pouvez vous me fournir les XML de ces 2 équipements (dans l'onglet 'fusinv XML')
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#15
Voici :
routeur VPN
#######

<?xml version="1.0"?>
<DEVICE>
<INFO>
<COMMENTS>Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(25d), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright © 1986-2010 by Cisco Systems, Inc.
Compiled Wed 18-Aug-10 04:40 by prod_rel_team</COMMENTS>
<ID>53</ID>
<IPS>
<IP>172.27.2.22</IP>
<IP>212.99.4.74</IP>
<IP>212.99.4.73</IP>
<IP>172.27.2.21</IP>
</IPS>
<LOCATION>RMS Grenoble </LOCATION>
<MAC>00:00:00:00:00:00</MAC>
<MODEL>CISCO1841</MODEL>
<NAME>vpn1.vpn.rms.loc</NAME>
<SERIAL>FCZ11161074</SERIAL>
<TYPE>NETWORKING</TYPE>
<UPTIME>26 days, 02:17:14.06</UPTIME>
</INFO>
<PORTS>
<PORT>
<CONNECTIONS>
<CDP>1</CDP>
<CONNECTION>
<IFDESCR>GigabitEthernet1/0/22</IFDESCR>
<IP>172.27.0.40</IP>
</CONNECTION>
</CONNECTIONS>
<IFDESCR>FastEthernet0/1</IFDESCR>
<IFINERRORS>31</IFINERRORS>
<IFINOCTETS>3088668153</IFINOCTETS>
<IFINTERNALSTATUS>1</IFINTERNALSTATUS>
<IFLASTCHANGE>15.24 seconds</IFLASTCHANGE>
<IFMTU>1500</IFMTU>
<IFNAME>Fa0/1</IFNAME>
<IFNUMBER>2</IFNUMBER>
<IFOUTERRORS>0</IFOUTERRORS>
<IFOUTOCTETS>3475169543</IFOUTOCTETS>
<IFSPEED>100000000</IFSPEED>
<IFSTATUS>1</IFSTATUS>
<IFTYPE>6</IFTYPE>
<MAC>00:1b:54:99:62:45</MAC>
</PORT>
<PORT>
<IFDESCR>Null0</IFDESCR>
<IFINERRORS>0</IFINERRORS>
<IFINOCTETS>0</IFINOCTETS>
<IFINTERNALSTATUS>1</IFINTERNALSTATUS>
<IFLASTCHANGE>0.00 seconds</IFLASTCHANGE>
<IFMTU>1500</IFMTU>
<IFNAME>Nu0</IFNAME>
<IFNUMBER>3</IFNUMBER>
<IFOUTERRORS>0</IFOUTERRORS>
<IFOUTOCTETS>0</IFOUTOCTETS>
<IFSPEED>4294967295</IFSPEED>
<IFSTATUS>1</IFSTATUS>
<IFTYPE>1</IFTYPE>
</PORT>
<PORT>
<CONNECTIONS>
<CDP>1</CDP>
<CONNECTION>
<IFDESCR>GigabitEthernet1/0/23</IFDESCR>
<IP>172.27.0.40</IP>
</CONNECTION>
</CONNECTIONS>
<IFDESCR>FastEthernet0/0</IFDESCR>
<IFINERRORS>232</IFINERRORS>
<IFINOCTETS>4006858975</IFINOCTETS>
<IFINTERNALSTATUS>1</IFINTERNALSTATUS>
<IFLASTCHANGE>15.23 seconds</IFLASTCHANGE>
<IFMTU>1500</IFMTU>
<IFNAME>Fa0/0</IFNAME>
<IFNUMBER>1</IFNUMBER>
<IFOUTERRORS>0</IFOUTERRORS>
<IFOUTOCTETS>1553256247</IFOUTOCTETS>
<IFSPEED>100000000</IFSPEED>
<IFSTATUS>1</IFSTATUS>
<IFTYPE>6</IFTYPE>
<MAC>00:1b:54:99:62:44</MAC>
</PORT>
</PORTS>
</DEVICE>
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#16
commutateur (extrait sion trop long : stack de 3 3750)
########

<?xml version="1.0"?>
<DEVICE>
<INFO>
<COMMENTS>Cisco IOS Software, C3750 Software (C3750-IPSERVICESK9-M), Version 12.2(55)SE, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright © 1986-2010 by Cisco Systems, Inc.
Compiled Sat 07-Aug-10 22:45 by prod_rel_team</COMMENTS>
<CPU>6</CPU>
<FIRMWARE>12.2(55)SE</FIRMWARE>
<ID>1585</ID>
<IPS>
<IP>172.27.0.40</IP>
</IPS>
<LOCATION>RMS Grenoble </LOCATION>
<MAC>00:1b:2b:20:40:80</MAC>
<MEMORY>33</MEMORY>
<MODEL>WS-C3750G-24T-S</MODEL>
<NAME>sw1.inf.rms.loc</NAME>
<RAM>128</RAM>
<SERIAL>CAT1109RGVK</SERIAL>
<TYPE>NETWORKING</TYPE>
<UPTIME>41 days, 06:53:36.46</UPTIME>
</INFO>
<PORTS>
.....
<PORT>
<CONNECTIONS>
<CDP>1</CDP>
<CONNECTION>
<IFDESCR>FastEthernet0/0</IFDESCR>
<IP>212.99.4.74</IP>
</CONNECTION>
</CONNECTIONS>
<IFDESCR>GigabitEthernet1/0/23</IFDESCR>
<IFINERRORS>0</IFINERRORS>
<IFINOCTETS>3245688497</IFINOCTETS>
<IFINTERNALSTATUS>1</IFINTERNALSTATUS>
<IFLASTCHANGE>2 days, 03:56:07.66</IFLASTCHANGE>
<IFMTU>1500</IFMTU>
<IFNAME>Gi1/0/23</IFNAME>
<IFNUMBER>10123</IFNUMBER>
<IFOUTERRORS>0</IFOUTERRORS>
<IFOUTOCTETS>851136551</IFOUTOCTETS>
<IFSPEED>100000000</IFSPEED>
<IFSTATUS>1</IFSTATUS>
<IFTYPE>6</IFTYPE>
<MAC>00:1b:2b:20:40:97</MAC>
<TRUNK>0</TRUNK>
</PORT>
......
<PORT>
<CONNECTIONS>
<CDP>1</CDP>
<CONNECTION>
<IFDESCR>FastEthernet0/1</IFDESCR>
<IP>172.27.2.22</IP>
</CONNECTION>
</CONNECTIONS>
<IFDESCR>GigabitEthernet1/0/22</IFDESCR>
<IFINERRORS>0</IFINERRORS>
<IFINOCTETS>949702179</IFINOCTETS>
<IFINTERNALSTATUS>1</IFINTERNALSTATUS>
<IFLASTCHANGE>2 days, 03:56:07.64</IFLASTCHANGE>
<IFMTU>1500</IFMTU>
<IFNAME>Gi1/0/22</IFNAME>
<IFNUMBER>10122</IFNUMBER>
<IFOUTERRORS>0</IFOUTERRORS>
<IFOUTOCTETS>2633042471</IFOUTOCTETS>
<IFSPEED>100000000</IFSPEED>
<IFSTATUS>1</IFSTATUS>
<IFTYPE>6</IFTYPE>
<MAC>00:1b:2b:20:40:96</MAC>
<TRUNK>0</TRUNK>


....


</PORTS>
</DEVICE>
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#17
Ok, je reproduit le soucis, je viens d'ajouter des tests unitaires la dessus, je vais corriger
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#18
Corrigé : http://forum.fusioninventory.org/viewtopic.php?pid=6331
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#19
Bravo.
Que dois-je mettre à jour pour bénéficier de cette correction : les paquetages snmpquery et netdiscovery sur l'agent et/ou le plugin sur le serveur GLPI ?
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#20
la correction sur le plugin (le diff est en lien dans le ticket)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#21
Je ne comprends pas : le lien que tu fournis me ramène sur ce même sujet du forum
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#22
oups je me suis foiré :p
voilà le bon :
http://forge.fusioninventory.org/issues/1419
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#23
Pas de pb. Mais comment dois-je appliquer ce changement sans casser mon install actuelle ? Avec la méthode git décrite sur http://fusioninventory.org/wordpress/dow...inventory/ ou en appliquant simplement le changement dans le code directement ?
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply
#24
En appliquant directement dans le code
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#25
Décidemment : la version de fusinvsnmp/inc/communicationsnmpquery.class.php que j'ai ne correspond pas vraiment (1381 lignes au lieu de 1452) et je n'ai pas de répertoire fusioninventory/phpunit.
Je suis perdu là ...
GLPI 0.80.7 + Fusion 0.80+1.5
  Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)