• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Impossible de joindre l'agent
#1
Bonjour,

J'utilise GLPI et OCS depuis plusieurs années sans rencontrer de difficultés. Je souhaite déployer Fusion-Inventory sans OCS (je n'utilise pas le télé-deploiement).
J'ai donc fait l'installation sur dix postes (8 XP et 2 Seven) de l'agent FusionInventory 2.1.23.1 et upgradé mon serveur GLPI vers la version 0.80.61.

Lorsque je force l'agent depuis les postes, les agents remontent bien dans GLPI.
Les inventaires automatiques (réglé sur 13 heures) fonctionnent aussi.
Toutes les machines répondent au test IP/status.

Par contre, lorsque je force l'agent depuis le serveur GLPI, j'ai l'erreur "Impossible de joindre l'agent!" qui s'affiche, mais uniquement pour les machines sous XP. Les PC sous Seven ne présentent pas se problème.

Pouvez vous m'aider ?

Cordialement
  Reply
#2
Peut être le firewall de windows XP activé? (port 62354)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
non aucun Firewall d'activé, ni aucun blocage d'antivirus (identique sur Seven et XP)
  Reply
#4
est -ce que ça répond : http://ipmachine:62354/status ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
oui status: waiting pour toutes les machines
  Reply
#6
Quand je clique sur "forcer l'inventaire" depuis GLPI voici le log de l'agent :

les X correspondent a l'adresse IP


[Mon Jan 16 13:30:18 2012][debug] [RPC] XX.XXX.X.XXX request /status
  Reply
#7
Etrange en effet, vous utilisez quelle version des plugins FusionInventory et sur quelle version de GLPI?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#8
j'utilise le plugin 2.4.0
  Reply
#9
Je viens de remplacer le plugin 2.4.0 par 0.80+1.1. Je viens de forcer l'inventaire en local sur un poste XP afin que l'agent remonte sur le serveur.
Maintenant pour ce poste je peux forcer l'inventaire depuis le serveur.

J'attends que mes dix postes remontent avant de crier victoire Smile

merci
  Reply
#10
super Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#11
Bonjour,

Je confirme que tout est ok, mes postes remontent en auto et le forçage des inventaires depuis le serveur est ok aussi.

Merci
  Reply
#12
Bonjour,

J'ai rencontré le même soucis que "bjct42" avec l'option pour forcer l'inventaire depuis le serveur sur les postes distants avec Windows XP alors que Windows 7 cela fonctionnait.

Donc j'ai suivis son astuces en enlevant le plugin 2.4.0 pour passer au0.8+1.1 avec la même réussite que lui, les postes en Windows XP et 7 fonctionne lorsque l'on veut forcer l'inventaire depuis le serveur mais je rencontre un autre petit soucis.
Avec les postes en Windows 7 32 et 64Bits, je peut forcer l'inventaire une fois mais après je n'ai plus accès à l'option "Forcer l'inventaire". Je voulais savoir si vous saviez d’où vient mon problème ?

Cordialement
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)