• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bug dans l'installeur Windows avec le nom du serveur ?
#1
J'ai constaté un souci avec l'installeur Windows de l'agent : si j'utilise le paramètre "/server=http://mon-serveur.domaine.tld/glpi/plugins/fusioninventory/", l'installation ne se fait pas, et à la place j'ai la fenêtre des options possibles.
Par contre, si je mets "/server=http://monserveur.domaine.tld/glpi/plugins/fusioninventory/" (sans le tiret), tout fonctionne normalement et l'installation se fait.
Est-ce normal docteur ?
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1
  Reply
#2
J'ai creusé un peu le bug, et voici comment j'arrive à le reproduire :
- avec la ligne de commande suivante, j'ai l'apparition de la fenêtre des paramètres qu'on obtient normalement avec l'option "/h" :
fusioninventory-agent_windows-i386_2.1.13-1.exe /S /runnow /rpc-trust-localhost /tag=Laxou /server=http://helpdesk-num.xxx.yyy/plugins/fusioninventory/
- si je prends un nom de serveur qui ne commence pas par la lettre "h", tout se passe bien, l'installation se fait et la fenêtre des paramètres n'apparaît pas :
fusioninventory-agent_windows-i386_2.1.13-1.exe /S /runnow /rpc-trust-localhost /tag=Laxou /server=http://num-helpdesk.xxx.yyy/plugins/fusioninventory/

On dirait que le parseur de l'installeur voit le "/h" dans "http://helpdesk-num", et que l'installation ne se fait pas. Donc ce n'est pas le tiret dans le nom, c'est le nom de serveur qui commence par "h" qui fait planter l'installation en ligne de commande.

Etonnant, non ? ;-)
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1
  Reply
#3
Oui on est au courant depuis quelques semaine, c'est très difficile a corriger, donc on demande à contourner en changeant le nom ou en mettant l'ip :/

Mais dans ton premier message, t'avais juste mis http://mon-serveur.domaine.tld donc on n'a pas pu te prévenir de ce soucis :p
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#4
OK, merci, je vais créer un alias de mon serveur "helpdesk" en "glpi", comme ça je n'aurai plus de problème ;-)
J'avais mal investigué mon problème au départ, je pensais que c'était le tiret qui me posait problème et pas le nom du serveur qui commençait par "h"...
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)